Fórum

Página de postagens.

Comunidade de discussão sobre ferramentas, soluções e serviços da Trustcode. Participe!

Welcome!

This community is for professionals and enthusiasts of our products and services. Share and discuss the best content and new marketing ideas, build your professional profile and become a better marketer together.

1

No module named pytrustnfe.nfe

By
Administrator
on 28/01/18 14:25 2.779 visualizações

Ao tentar instalar algum módulo no Odoo v10 com a localização brasileira da TrustCODE recebo a seguinte mensagem de erro:

O módulo "br_base" não pode ser instalado porque uma dependência externa não foi encontrada: No module named pytrustnfe.nfe

Esta pergunta foi incluída no Documentação Oficial .

1

Administrator

--Administrator--
2807
| 0 0 0
--Administrator--
Administrator
On 28/01/18 14:25

Para corrigir o problema basta rodar o seguinte comando:

pip install PyTrustNFe

Esta pergunta foi incluída no Documentação Oficial .

0

Administrator

--Administrator--
2807
| 0 0 0
--Administrator--
Administrator
On 28/01/18 14:25

Boa Noite, 


Instalei o Odoo em um Debian 8, tudo funcionando perfeitamente depois fui instalar a localização da TrustCode, na hora de instalar os modulo Contabilidade, Faturamento ou qualquer outro que esta relacionado com o certificado, aparece a mensagem abaixo :

"O módulo 'br_base' não pode ser instalado porque uma dependência externa não foi encontrada: No module named pytrustnfe.nfe"


Executei a instalação deste pacote com  "pip install pytrustnfe" e neste modulo esta aparecendo um erro na instalação do cryptography como segue o log :


Failed cleaning build dir for cryptographyFailed to build cryptographyInstalling collected packages: cryptography, pyOpenSSL, lxml, future, eight Found existing installation: cryptography 0.6.1 Can't uninstall 'cryptography'. No files were found to uninstall.

  Running setup.py install for cryptography ... error

Depois de muito teste fazendo varias vezes a instalação e desinstalação destes modulo, cheguei a seguinte conclusao o meu problema esta no pacote cffi versao instalada 1.9.1 porem o cryptography pede a versao cffi 0.8.6 e não consigo acertar.


Alguém poderia me ajudar.


At.


Evandro Josias


Esta pergunta foi incluída no Documentação Oficial .

0

Administrator

--Administrator--
2807
| 0 0 0
--Administrator--
Administrator
On 28/01/18 14:25

Tenta:

sudo apt-get install python-dev

sudo pip install ansible


Esta pergunta foi incluída no Documentação Oficial .

0

Administrator

--Administrator--
2807
| 0 0 0
--Administrator--
Administrator
On 28/01/18 14:25

O meu também deu erro, fiz o seguinte (como root).

1) baixei o pacote com o "pip download PyTrustNFe"

2) Descompactei o arquivo "PyTrustNFe-0.1.10.tar.gz" e apague ele, vamos criar outro depois

3) copiei um "README.md" de qualquer outro local pra dentro da pasta "PyTrustNFe-0.1.10"

4) Crie novamente o arquivo usando o comando tar "tar cvfz PyTrustNFe-0.1.10.tar.gz.tar.gz  PyTrustNFe-0.1.10/*"

5) instale o pacote usando "pip install PyTrustNFe-0.1.10.tar.gz.tar.gz"

O problema é a falta do README.md nesse pacote.

Comigo funcionou,

[]'s

Fabio.


Esta pergunta foi incluída no Documentação Oficial .

0

Administrator

--Administrator--
2807
| 0 0 0
--Administrator--
Administrator
On 28/01/18 14:25

E no windows?

Como corrigir este problema?


Fique Informado

A Comunidade

Essa comunidade foi feita para profissionais e interessados nos nossos produtos e serviços.

Compartilhe e debata sobre os melhores conteúdos e novas ideias sobre o mercado.

Construa seu perfil profissional e se torne um melhor conhecedor de negócios conosco.
Leia Orientações

Ferramentas de Pergunta

0 seguidor (es)

Estatísticas

Perguntada: 28/01/18 14:25
Visto: 2779 vezes
Última atualização: 20/06/18 22:41